Firefox最近升级的很快,最新的发行版是Firefox 12.0了,还有网友在用3.6.x,不少网友为了尝鲜,可能会升到最新版。但是会出现有些插件不兼容的情况,会提示版本不符,无法安装。其实我们可以做下小小的修改,就可以在新版本上用上这些旧的插件。修改后的插件,基本都没大的问题,除个别的不能使用外,大多数都可以正常的使用。

我们要用到WinRAR压缩软件来修改

打开WinRAR,然后把插件文件xpi拖进来

我们看到,有一个install.rdf文件,把这个文件解压到桌面来修改,方法:【右键】-->【解压到指定文件夹】

然后用记事本打开install.rdf文件进行修改

            <Description>
                <em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
                <em:minVersion>1.0</em:minVersion>
                <em:maxVersion>30.6.*</em:maxVersion>
            </Description>

这里maxVersion就是这个插件能支持的最大版本号了,我们可以修改的大一些,比如我这个改成了30。

发表评论

您的电子邮箱地址不会被公开。