Zend Guard代替Zend Optimizer 支持php5.3/php5.4

By admin  2012年11月27日 Linux 关注度 3,070 添加评论

服务器的php的版本是php5.3,但是Zend Optimizer不支持php5.3,经过各种努力,终于可以使用了。

1、下载Zend Guard
支持php5.3
32位 http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-i386.tar.gz
64位 http://downloads.zend.com/guard/5.5.0/ZendGuardLoader-php-5.3-linux-glibc23-x86_64.tar.gz

支持php5.4

32位 ZendGuardLoader-70429-PHP-5.4-linux-glibc23-i386.tar

64位 ZendGuardLoader-70429-PHP-5.4-linux-glibc23-x86_64.tar

2、将ZendGuardLoader.so复制到/usr/lib/php5/20090626+lfs目录下面

3、在/etc/php5/conf.d目录下面新建zend.ini,写入

zend_extension=”/usr/lib/php5/20090626+lfs/ZendGuardLoader.so”

4、重启服务器

service nginx restart

5、输入php -m|grep Zend,出现

Zend Guard Loader
[Zend Modules]
Zend Guard Loader

则为成功

发表评论