debian-7.0-x86_64安装出错解决方法

By admin  2013年08月10日 Linux 关注度 21,755 添加评论

debian-7.0-x86_64在安装web环境时,执行命令

apt-get update && apt-get -y upgrade && apt-get -y dist-upgrade

当更新源和升级时,出现以下错误

Reading package lists…

Building dependency tree…
Reading state information…
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
15 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing libgcrypt11:amd64 (–configure):
 package libgcrypt11:amd64 1.5.0-5+deb7u1 cannot be configured because libgcrypt11:i386 is at a different version (1.5.0-5)
dpkg: error processing libgnutls26:amd64 (–configure):
 package libgnutls26:amd64 2.12.20-7 cannot be configured because libgnutls26:i386 is at a different version (2.12.20-6)
dpkg: error processing libkrb5support0:amd64 (–configure):
 package libkrb5support0:amd64 1.10.1+dfsg-5+deb7u1 cannot be configured because libkrb5support0:i386 is at a different version (1.10.1+dfsg-5)
dpkg: error processing libk5crypto3:amd64 (–configure):
 package libk5crypto3:amd64 1.10.1+dfsg-5+deb7u1 cannot be configured because libk5crypto3:i386 is at a different version (1.10.1+dfsg-5)
dpkg: error processing libkrb5-3:amd64 (–configure):
 package libkrb5-3:amd64 1.10.1+dfsg-5+deb7u1 cannot be configured because libkrb5-3:i386 is at a different version (1.10.1+dfsg-5)
dpkg: error processing libgssapi-krb5-2:amd64 (–configure):
 package libgssapi-krb5-2:amd64 1.10.1+dfsg-5+deb7u1 cannot be configured because libgssapi-krb5-2:i386 is at a different version (1.10.1+dfsg-5)
dpkg: error processing libsasl2-2:amd64 (–configure):
 package libsasl2-2:amd64 2.1.25.dfsg1-6+deb7u1 cannot be configured because libsasl2-2:i386 is at a different version (2.1.25.dfsg1-6)
dpkg: error processing libdbus-1-3:amd64 (–configure):
 package libdbus-1-3:amd64 1.6.8-1+deb7u1 cannot be configured because libdbus-1-3:i386 is at a different version (1.6.8-1)
dpkg: dependency problems prevent configuration of libdns88:
 libdns88 depends on libgssapi-krb5-2 (>= 1.10+dfsg~); however:
  Package libgssapi-krb5-2:amd64 is not configured yet.

dpkg: error processing libdns88 (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of libisccfg82:
 libisccfg82 depends on libdns88; however:
  Package libdns88 is not configured yet.

dpkg: error processing libisccfg82 (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of libbind9-80:
 libbind9-80 depends on libdns88; however:
  Package libdns88 is not configured yet.
 libbind9-80 depends on libisccfg82; however:
  Package libisccfg82 is not configured yet.

dpkg: error processing libbind9-80 (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of bind9-host:
 bind9-host depends on libbind9-80 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libbind9-80 is not configured yet.
 bind9-host depends on libdns88 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libdns88 is not configured yet.
 bind9-host depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
  Package libgssapi-krb5-2:amd64 is not configured yet.
 bind9-host depends on libisccfg82 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libisccfg82 is not configured yet.

dpkg: error processing bind9-host (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of bind9utils:
 bind9utils depends on libbind9-80; however:
  Package libbind9-80 is not configured yet.
 bind9utils depends on libdns88; however:
  Package libdns88 is not configured yet.
 bind9utils depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
  Package libgssapi-krb5-2:amd64 is not configured yet.
 bind9utils depends on libisccfg82; however:
  Package libisccfg82 is not configured yet.

dpkg: error processing bind9utils (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of bind9:
 bind9 depends on libbind9-80 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libbind9-80 is not configured yet.
 bind9 depends on libdns88 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libdns88 is not configured yet.
 bind9 depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
  Package libgssapi-krb5-2:amd64 is not configured yet.
 bind9 depends on libisccfg82 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package libisccfg82 is not configured yet.
 bind9 depends on bind9utils (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u1); however:
  Package bind9utils is not configured yet.

dpkg: error processing bind9 (–configure):
 dependency problems – leaving unconfigured
dpkg: dependency problems prevent configuration of sasl2-bin:
 sasl2-bin depends on libsasl2-2 (>= 2.1.25.dfsg1-6+deb7u1); however:
  Package libsasl2-2:amd64 is not configured yet.
 sasl2-bin depends on libgssapi-krb5-2 (>= 1.6.dfsg.2); however:
  Package libgssapi-krb5-2:amd64 is not configured yet.
 sasl2-bin depends on libk5crypto3 (>= 1.6.dfsg.2); however:
  Package libk5crypto3:amd64 is not configured yet.
 sasl2-bin depends on libkrb5-3 (>= 1.7dfsg); however:
  Package libkrb5-3:amd64 is not configured yet.

dpkg: error processing sasl2-bin (–configure):
 dependency problems – leaving unconfigured
Errors were encountered while processing:
 libgcrypt11:amd64
 libgnutls26:amd64
 libkrb5support0:amd64
 libk5crypto3:amd64
 libkrb5-3:amd64
 libgssapi-krb5-2:amd64
 libsasl2-2:amd64
 libdbus-1-3:amd64
 libdns88
 libisccfg82
 libbind9-80
 bind9-host
 bind9utils
 bind9
 sasl2-bin

经过查看,发现x86_64这个模板,有i386和amd64二种包,存在冲突了

首先让内核在i386下面工作

dpkg –add-architecture i386

apt-get update

apt-get -y upgrade

apt-get -y dist-upgrade

发表评论